Robinson's Requiem AGA Amiga

New Comment

Post a new comment to participate in the discussion on how this game should be configured, or to add relevant information regarding the use of these configurations.

Posted by Nolendil at 2021-03-30 04:41:36 (Updated 2021-03-30 06:14:48):


The graphical glitch feels familiar indeed.

Just to make sure I tested with WinUAE too. (It took me a while to prepare it for WHDLoad which reminded me how great FS-UAE is in that regard smiley ) As you said, it works fine in WinUAE 4.4.0 even with the configuration that was glitching (020 and 8 MB of Z2 fast mem).

So it's probably not related to whatever WHDLoad does with fast memory but it may be an emulation bug in FS-UAE, actually. After all, its emulation core is quite old compared to the current version of WinUAE. Until further updates, the current config is good enough though.

Posted by thevoice at 2021-03-29 14:27:25:

@Nolendil hi, the buggy display looks exactly like if you star a non AGA game on an AGA machine. at least i just saw such graphics corruption in such cases. also the whdload installer is already 7 or 8 years old. but still it works flawless with winuae. so i think we should wait for the next fs-uae version and see if this problem autosolves. if not we can make @frode dig into that issue wink.

Posted by Nolendil at 2021-03-28 23:44:04 (Updated 2021-03-29 00:12:22):

@thevoice Thanks for the config update, I think reducing the fast mem to 4 MB is a safe choice. Changing CPU produced more random results (something to do with timings?).

As for the version of WHDLoad, the most recent is indeed 18.6. However, when I said "WHDLoad changelog mentions memory allocation fixes", I meant the changelog of the game installer, here:

version 1.2 (29.03.13) done by CFou!:

  • First two bitplanes memory allocation fixed for fast memory support (AGA)
  • Speed problem fixed on ECS version
  • Fast memory used to increase speed (AGA/ECS)
  • source codes included

I was wondering if those changes related to fast mem could be the reason of the display bugs.

Posted by thevoice at 2021-03-27 05:08:38:

@Nolendil hi, thanks for the deep testing, and indeed the game starts correctly with fastmem reduced to 4mb. fs-uae launcher uses whdload version 18.5.5849 at the moment. i doubt this one is somewhat the current version. i assume @frode will also update whdload to current once he releases the next version of the fs-uae package. so for now i change fastmem to 4mb as a workaround which shouldn't be a problem as the whdload info says it requires only 1.7mb fastmem for the aga version.

Posted by Nolendil at 2021-03-27 00:31:38 (Updated 2021-03-28 23:45:15):

I reproduced the bug Luikuri and thevoice found but some of my test results seemed slightly random. Hopefully this helps though.

  • I started the game for the first time ever on this PC using the default configuration: it worked perfectly fine.
  • I then changed the model to A1200 + Blizzard 1260 and this time I had the same garbled graphics issue mentioned in the comments below.
  • When I switched back to the default configuration, it was broken too this time (??).

I tried to find if FS-UAE saves something between the sessions that would explain the changing behavior, without success. FS-UAE's log also says the save state was empty and not saved. Quitting and relaunching the emulator didn't seem to have any effect either.

Then, I kept changing the CPU configuration (from the model list) and now it seems to work fine for any A1200 configuration with at least a 030 CPU (including the 060 configuration that was previously broken). However I randomly managed to make it work again twice with a 020 configuration (out of a dozen attempts).

Using the default configuration with the fast mem reduced to 2 or 4 MB (instead of 8) seems to fix the problem too! The WHDLoad changelog mentions memory allocation fixes. Maybe that fix doesn't work for 020 with 8 MB of fast mem?

All tests were done with v 1.2 of the WHDLoad install and FS-UAE 3.0.5 with an up-to-date Game database, on Windows 10.

Posted by thevoice at 2021-03-20 15:03:47:

@Luikuri ok then it looks like it is a problem with fs-uae. @frode can you have alook what is going on here ?

Posted by Luikuri at 2021-03-20 10:11:05:

Yes, I'm using Win10. The game works fine with Gamebase/WinUAE322, which I used for the screenshots.

Posted by thevoice at 2021-03-19 16:21:19:

@Luikuri ok i tried every possible aga configuration '(since the game is aga) and always got the same graphical issue as you had. do you use fs-uae for windows ? since i use fs-uae in linux. so if this problem shows up on different platforms it may be a problem with the whdload slave which is 8 years old now. or if you have access to winuae, can you test if the game have the same issues there ?

Posted by thevoice at 2021-03-19 16:13:03:

@Luikuri hi, thanks for your comment. i will see what happen with this install. what i can tell you for sure the game does not need 8mb chip memory since no amiga model ever supported more then 2mb chip memory wink.

Posted by Luikuri at 2021-03-19 15:11:45:

Doesn't work with current settings in FS-UAE; the screen is all horizontal lines (I'm sure there is a term for this). Also the game needs more (8MB?) chip RAM to display the full 3D window.