Cannon Fodder Amiga

New Comment

Post a new comment to participate in the discussion on how this game should be configured, or to add relevant information regarding the use of these configurations.

Posted by MEON at 2020-12-08 11:09:42:

Hello, is it possible to run cannon fodder on the FS-UAE emulator? Because when he gives them all he shows me that the game files are missing. I read here and there was such a problem, but for me it still seems to be fixed. I'd love to play this game, but I can't.

Posted by FrodeSolheim at 2017-08-27 14:42:07:

The problem is fixed now smiley

Posted by FrodeSolheim at 2017-08-27 12:34:08 (Updated 2017-08-27 14:04:19):

I did do a mistake with a maintenance script on friday, which disabled a lot of games "at random" until I stopped/fixed it. I thought I reversed the changes (and I did), but I did not clean up properly (some cached information in database were not properly updated).

I've identified the problem and running a fix now. Games should be back "online" relatively soon smiley

Thanks for reporting! smiley

Posted by 33a0c968 at 2017-08-27 12:31:02:

Random games everywhere in the entire database seems to be disabled, actually. A lot of games in my own launcher just disappeared when I updated the game database

Posted by FrodeSolheim at 2017-08-27 12:09:25:

@pb_ @thevoice There is some bug somewhere. This game is not really marked as disabled, but for some reason, it is after all (in the game browser here on and also it's not synced to the Launcher).

Must have happened recently, I think. I'm currently investigating...

Posted by thevoice at 2017-08-26 05:42:40 (Updated 2017-08-26 05:49:53):

@pb_ beside this title have no disabled variants, disabled means the title has known broken diskimages, iis just disks which can be installed to hd only or in other ways entirely not useable with the launcher.

Posted by pb_ at 2017-08-25 14:57:50:

why is this game "disabled"? what does it mean (aside from the fact that it's not automatically detected in fs-uae)?

Posted by thevoice at 2016-03-02 14:16:57:

ADF, IT, cr Technobrains

the cracktro requires a600 model , with a500 model just a graphic is shown but the intro hangs otherwise.

Posted by FrodeSolheim at 2014-02-26 22:28:58 (Updated 2014-02-26 22:29:28):

@gazchap It looks like the games are not fully saved until the WHDLoad slave quits. So this game must be quit with the WHDLoad slave quit key ('DEL' for this slave) in order for the games to be fully saved. I'll add a warning for the whdload variant.

Posted by gazchap at 2013-12-30 20:27:28:

When saving games in the WHDLoad version of Cannon Fodder in FS-UAE (loading direct from the WHDLoad zip) the save games don't carry across to the next launch, even though they're in the cf_data folder (copied over from the States folder in FS-UAE's data dir)

Any ideas?

Posted by DaveMB at 2013-10-07 18:58:28:

Hi, thanks for checking, I grabbed the FLT save fixed version from TOSEC and it works fine now, It's the same version I already had so either I had a corrupt .adf or the version from GameBase is bad.

Posted by FrodeSolheim at 2013-10-06 21:11:15:

@DaveMB I couldn't get "ADF, cr FLT" to crash with default settings right now, but I guess there is a reason why "cr FLT, f load - save FLT" exists. EDIT: can't get "ADF, cr FLT, f load - save FLT, t +4 PDX" to crash either. Perhaps it only happens if you have played some levels? I only tried saving at start and after level 1.

Posted by DaveMB at 2013-10-06 19:35:30 (Updated 2013-10-06 19:54:36):

sorry if this has been mentioned but the FLT crack requires 1mb chip otherwise it will crash when you try to save.

Edit, The version I have (PDX trained) is supposed to be 'save fixed' but still crashes on 512k ~real hardware and emulated~

Posted by pottyboy at 2013-03-28 15:36:48:

Both IPF and WHDLoad versions work fine. However, for those using the Mac OS version of FS-UAE with an Apple trackpad or mouse (even ones with two buttons), you will need to assign the right mouse button to a keyboard key (such as TAB), otherwise grenades can't be thrown thus making the game non-completable.

Posted by TCD at 2013-03-11 08:01:44:

No... I just fixed them all... please check first before you 're-fix' things and cause even more work...

Posted by thevoice at 2013-03-11 07:58:32:

why oh why cant obvious things just obvious. fixing all then smiley

Posted by TCD at 2013-03-11 07:41:46:

@thevoice: For a list of common cracktro_action values, please have a look here:

Posted by thevoice at 2013-03-11 05:56:41:

technobrains IT versions cracktro requires 1mb chip. fixed that

Posted by FrodeSolheim at 2013-01-04 21:04:41:

I have updated the TOSEC disk matching algorithm, and it is significantly improved. The Cannon Fodder variants (and all other variants) have been updated where necessary.

Posted by thevoice at 2012-12-10 18:20:00:

tosec is easy how disks are chosen on multidiskers. lets say a crack is made by flt and disk 1 have a triner by xyz. all other disks labeled cr FLT are the right ones. if there is several cracked variants of disk 1 and other disks dont mention cr XXX then all cracks use the same disks 2-x.

Posted by FrodeSolheim at 2012-12-10 18:17:42:

TODO: I have created a program which tries to match disks as good as possible, but I agree that the variants you point at here seems a bit weird. I will review the algorithm and check why those disks were chosen wink

Posted by thevoice at 2012-12-10 18:08:26:

ADF, cr FLT, f load - save FLT, t +4 PDX, ADF, cr FLT, f load - save FLT, t +5 MST for the tosec variants.

how are those disks chosen ? random ? throwing a coin ? if you check the required disks both of the named sets want a 2nd disk which have an .lha archive for hd installation xD

for tosec there is kinda some rule how to chose disks.

Cannon Fodder (1993)(Virgin)(Disk 1 of 3)[cr FLT][f load - save FLT][t +5 MST].zip Cannon Fodder (1993)(Virgin)(Disk 2 of 3)[cr FLT].zip Cannon Fodder (1993)(Virgin)(Disk 3 of 3)[cr FLT].zip

that is how the +5 mystic trained version should look like. the +4 paradox one also use the same disk 2&3 like the mystic trained one.

Posted by nexusle at 2012-12-02 20:15:07:

If this is so, than I agree with you. But, for example, at Indy 4 it's senseful to use A1200 to speed up the game significantly! I've tried it with A600 and it was nearly unplayable...

Posted by FrodeSolheim at 2012-12-02 20:07:03:

Just to clarify, you actually need about twice as powerful a computer to emulate A1200 than A5/600. This is because most of the time is spent emulating the CPU, especially in cycle-exact mode.

Posted by FrodeSolheim at 2012-12-02 20:05:26:

No, I agree with the principle of trying to use standard models as much as possible. But cycle-exact A1200 emulation is much more demanding than A600 (mainly due to the 14Mhz vs 7Mhz CPU), and especially when you try to run with perfect scrolling at 50Hz / vsync, you need all frames to be completed more than quickly enough. So even on quite powerful computers, A1200 emulation can cause stuttering due to some frames taking just a bit too long, so that texture upload and rendering is not done in time for the next vblank. This is not in itself a gigantic problem, and computers get faster all the time. But my point is that if there is no other known problem running with a A600 with extra chip RAM in this case, that is probably the better solution (only upsides, no downsides?).

Posted by nexusle at 2012-12-02 19:41:24:

Do you know a A600 with originally 2MB ChipMem?!

I think we should use more original models as pimp other models.

Whats the difference between A600 and A1200 emulation? I can't find any problems on my 5 year old iMac...

Posted by FrodeSolheim at 2012-12-02 19:25:51:

You're right, I tested the WHDLoad version and it says it needs 1088 KB chip RAM. However, if the game otherwise works on Amiga 600 (much lighter to emulate) and Amiga 1200 brings no other advantage, I should perhaps rather make available a chip_memory key, so we can set chip_memory = 2048 instead.

Posted by nexusle at 2012-12-02 11:57:04:

Changed Amiga model of the normal WHDLoad version to A1200, because WHDLoad asked for more that 1 meg of Chip RAM.

Posted by nexusle at 2012-12-02 11:53:37:

Changed the chipset for the CD32 WHDLoad version to AGA.